SYSTEM-WIDE MAINTENANCE
Resolved
Jun 24, 2026 at 6:08pm UTC
Maintenance ended
Affected services
Created
Jun 24, 2026 at 2:08pm UTC
SYSTEM-WIDE MAINTENANCE NOTICE
Not started yet · Jun 17, 2026 2:11 PM GMT-04:00
SYSTEM-WIDE MAINTENANCE NOTICE
THE EPIC CAKE NETWORK + COSMOS+ NETWORKS SYSTEMS WILL BE UNDER GLOBAL MAINTENANCE
This is a scheduled maintenance period to improve performance, stability, and security across all services.
What to Expect
There will be downtime during this maintenance
Temporary service interruptions across multiple systems
Limited or no access to certain features and services
Possible delays in automated processes
Notes
This maintenance is planned and controlled
Systems will be restored as quickly as possible
No data loss is expected
Status
Maintenance is currently in progress. Please standby while upgrades are being completed.
@TECIT
Starts Jun 24, 2026 10:08 AM GMT-04:00 · Duration 4h 50m
Affected services